博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ 3624 Charm Bracelet【01背包】
阅读量:6957 次
发布时间:2019-06-27

本文共 1400 字,大约阅读时间需要 4 分钟。

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 61 42 63 122 7

Sample Output

23

思路

简单01背包进行套用模板即可:

for i=1…..N

  for v=V….0

      f[v]=max(f[v], f[v-c[i]]+w[i];

源码

#include<stdio.h>

#include<string.h>

#include<iostream>

using namespace std;

int main()

{

       int w[3500], d[3500], m, n, i, bag[15000], j;

       while(scanf("%d%d", &n, &m)!=EOF)

       {

              memset(bag, 0, sizeof(bag));

              for(i=1; i<=n; i++)

                     scanf("%d%d", &w[i], &d[i]);

              for(i=1; i<=n; i++)

                     for(j=m; j>=w[i]; j--)

                     {

                                   bag[j]=max(bag[j], bag[j-w[i]]+d[i]);

                     }

              printf("%d\n", bag[m]);

       }

}

转载于:https://www.cnblogs.com/Hilda/archive/2012/07/31/2616900.html

你可能感兴趣的文章
天鹅会面
查看>>
Python2爬取学生名单
查看>>
Python调用 c++ dll,并且使用Py2exe打包
查看>>
前端MVC的概念了解
查看>>
git在多迭代版本的应用
查看>>
Chrome好用的插件:Wappalyzer 检测网站使用的技术
查看>>
IT兄弟连 JavaWeb教程 经典面试题3
查看>>
CentOS下内核TCP参数优化配置详解
查看>>
Compuer Science - Markdown - Syntax
查看>>
Sort List
查看>>
Android studio preview界面无法预览,报错render problem
查看>>
对称加密
查看>>
Window-CPU-M Benchmark
查看>>
069、Calico的默认连通性(2019-04-12 周五)
查看>>
转——jdbcType与javaType的对应关系
查看>>
Digital Image Processing 学习笔记2
查看>>
软件工程阅读作业2
查看>>
startup的过程和启动代码
查看>>
字典dic内部常用功能和使用方法-课堂笔记及课后总结
查看>>
include,require,include_once,require_once 的作用和区别
查看>>